Attention!!™
Kafuka Mosts 2018
Voting is open! Get your votes in now!
Join the Kafuka Discord! (Click here)
Views: 5,790,699
Main | FAQ | IRC chat | Memberlist | Active users | Latest posts | Calendar | Stats | Ranks | Online users | Search
12-10-18 03:50 PM
Guest: Register | Login

0 users currently in AcmlmBoard Developer Zone | 1 guest

Main - AcmlmBoard Developer Zone - displayname issue
Next older thread


yoshi
Posted on 11-18-18 06:39 PM Link | ID: 144155
Newcomer

Level: 2


Posts: 1/2
EXP: 13
Next: 33

Since: 11-18-18

Last post: 3 days
Last view: 3 days
now, i don't know if this is the right forum to post this thread on, but if it isn't, please move it.

i've set up a instance of acmlmboard 2 on my server and i did import the main.sql file into the database + some other optional files successfully.

so i tried to register my account but i had this error after i registered:


Registration failed: Field 'displayname' doesn't have a default value


i do not know what is causing this. i tried to google for the error but no result. it gave me some results about sql being in strict mode or something but i am not sure if that's the reason why it's giving me this error.

any tips or help will be greatly appreciated.

Epele
Posted on 11-19-18 01:25 AM Link | ID: 144177
Acmlmistrator
The Sorceress.
The new champion

Level: 211


Posts: 19431/19575
EXP: 137885873
Next: 845764

Since: 01-01-12
From: UK

Last post: 3 hours
Last view: 4 min.
I've done some testing. Yes, the issue is the sql engine being in strict mode.

Due to the structure of the how the database is, a lot of work would be needed to get it up and running on a strict mode db as strict mode requires every single field to have a non-blank default value or the code specify it as a not-null blank data value. As such, any part of the board which does a sql insertion would need to be modified to ensure full compatibility.

If you have the ability to modify the sql mode on your server, the following sql query can be used to turn off strict mode. Exercise Caution though.
set global sql_mode='NO_ENGINE_SUBSTITUTION'



<Nicolyn> Thierry doesn't sleep
<Nicolyn> she is powered solely by those little floating hearts

yoshi
Posted on 12-06-18 04:31 PM Link | ID: 144930
Newcomer

Level: 2


Posts: 2/2
EXP: 13
Next: 33

Since: 11-18-18

Last post: 3 days
Last view: 3 days
ok so i switched to a non-sql strict mode host
and i was able to succesfully install acmlmboard 2 and register my account
however i can't log in for some reason

Next older thread
Main - AcmlmBoard Developer Zone - displayname issue


Acmlmboard v2.5.4 (10/13/2018)
© 2005-2018 Acmlm, Emuz, et al.

Page rendered in 0.037 seconds. (614KB of memory used)
MySQL - queries: 65, rows: 456/490, time: 0.020 seconds.